Kameleon Portal, Office and Teams add-in down

Incident Report for Kameleon

Resolved

Microsoft resolved issue with Azure Front Door at 00:05 UTC on 30 October 2025 – AFD impact confirmed mitigated for customers.
Posted Oct 30, 2025 - 00:15 UTC

Identified

Starting at approximately 16:00 UTC, customers and Microsoft services that leverage Azure Front Door (AFD) may have experienced issues resulting in latencies, timeouts and errors. Kameleon is utilizing AFD as CDN for Kameleon static assets.

Follow Microsoft status and updates here: https://azure.status.microsoft/en-gb/status
Posted Oct 29, 2025 - 16:00 UTC
This incident affected: Office add-in, Teams add-in, and Portal.