Microsoft Office Update Issue Affecting Taskpane Add-ins

Incident Report for Kameleon

Update

Microsoft is actively investigating this as a high-priority issue. A fix is in progress, and updates will be shared as they become available. In the meantime, please use the provided workaround
Posted Sep 18, 2025 - 09:44 UTC

Identified

A recent update to Microsoft Office (version 2507) has introduced a compatibility issue that affects taskpane JavaScript add-ins. This is not a bug in our product, but a known issue in Microsoft’s Office platform. You can follow the official tracking here: https://github.com/OfficeDev/office-js/issues/5979.

Error:
- Admin managed Add-in fail to load after Office upgrade with "You don't have permission to use this add-in"

How to Resolve:
To fix the issue, users should clear the Office cache using Microsoft’s recommended method:
https://learn.microsoft.com/en-us/office/dev/add-ins/testing/clear-cache#automatically-clear-the-cache

After clearing the cache, restart the Office application and try again.

Additional Notes:
- This issue is under investigation by Microsoft.
- We will update this page as soon as a fix is released.
- No changes have been made to our add-in or deployment process.
Posted Sep 12, 2025 - 07:08 UTC
This incident affects: Office add-in.